MacMusic  |  PcMusic  |  440 Software  |  440 Forums  |  440TV  |  Zicos
rsquo
Search

MacBook Pro’s MagSafe 3 cable is flashing yellow? macOS Monterey might be the problem

Monday November 22, 2021. 11:00 AM , from Mac 911
The latest revision to Apple’s magnetically coupled laptop charging system, MagSafe 3, appeared just weeks ago in the new 14-inch and 16-inch MacBook Pro with the M1 Pro or M1 Max processors. Some reports of charging difficulties quickly followed.

Some users have found that they have a persistent flashing yellow LED—Apple calls the color amber—on their MagSafe 3 cable’s magnetic connector when correctly plugged into the port and the included USB-C adapter. MagSafe has always made it effectively impossible to plug in its connector the wrong way: either it makes the right contact with multiple charging elements and can pass power, or it doesn’t. (If charging properly, the cable head’s LED should be a solid yellow; when fully charged, green.)

However, even if the cable head’s indicator is flashing yellow, charging continues—just seemingly not using the “fast charge” feature that can add a 50 percent charge to a low battery within 30 minutes when using the MagSafe 3 connector with the right power adapter.

This problem doesn’t appear widespread, but it’s common enough you can find people in online forums trying to find answers, and a Macworld reader experienced it first-hand. Owners have worked through several ideas to fixing the problem: getting Apple to replace the cable, adapter, or both, or even swap out the entire laptop. People have reinstalled macOS, and even used the complicated Apple Configurator 2 option to restore the M1-series Mac’s firmware. (See “How to revive or restore an unresponsive Mac from another Mac.”)

Some people report that Apple phone support told them to shut down their Mac and then hold down Control-Option-Shift at restart. That would be great…except it’s a feature that only works with Intel Macs, and only Intel Macs that shipped before around 2016 and lack the T2 Security Chip.

If you’re having this problem, it may actually be a firmware issue related to Monterey’s 12.0.1 release. In a confusing sequence, Apple shipped macOS 12.0.1 almost immediately after the initial release of Monterey. However, the 14-inch and 16-inch MacBook Pros were already in production, and the 12.0.0 system release had been preinstalled onto their SSDs. When first powering up one of these models, buyers were prompted to install 12.0.1. Based on reports, people who haven’t yet upgraded to 12.0.1 are not seeing the flashing-yellow issue.

If you’re experiencing this problem, time may solve it. The 12.1 release of Monterey should appear in the new future with several new features—and hopefully a fix for this one.

This Mac 911 article is in response to a question submitted by Macworld reader Mike.

Ask Mac 911

We’ve compiled a list of the questions we get asked most frequently, along with answers and links to columns: read our super FAQ to see if your question is covered. If not, we’re always looking for new problems to solve! Email yours to mac911@macworld.com, including screen captures as appropriate and whether you want your full name used. Not every question will be answered, we don’t reply to email, and we cannot provide direct troubleshooting advice.
https://www.macworld.com/article/553500/if-your-new-macbook-pros-magsafe-3-cable-is-flashing-yellow-...

Related News

News copyright owned by their original publishers | Copyright © 2004 - 2022 Zicos / 440Network
Current Date
Jan, Thu 27 - 12:23 CET